Documentation › Why aren’t my posts showing the right content?

Why aren’t my posts showing the right content?

If you click on your your post title and are not seeing your post content showing or you are seeing more of a post archive instead, the usual reason is quite simple:  the layout that is being applied to your posts has a content block set to custom query mode.

If the layout being applied to the posts is…

Single, Single » Post or a Shared Layout

You probably cloned a layout that had a content block set to custom query. Change your content block to default mode as opposed to custom query.  For the correct content to show, the mode must be set to default.

Front Page or Blog Index through inheritance

For more in inheritance please see this article on Layout Inheritance.

You need to customize either Single or  Single » Post or apply a shared layout to Single or  Single » Post where the content block it set to default mode.

How do you know whether you should customize Single or  Single » Post?  If you want your posts and pages to have the same layout and design, then customize Single.  If you want posts and pages to have a different layout or design, then you can do it three ways:

  1. Customize  Single to apply to Posts and Single » Page to apply to Pages
  2. Customize Single to apply to Pages and Single » Post to apply to Posts
  3. Customize Single » Post to apply to Posts and Single » Page to apply to Pages (leaving Single to still inherit from either the Blog Index or the Front page, depending upon your setup).

This article was last updated for Headway version 3.8.3

Copyright © 2016 Vesped Inc. All Rights Reserved. Proudly Powered by Headway and WordPress